Список форумов   Список форумов  

Помогите!!!

Всё о программировании на Labview

Модераторы: Техподдержка NI, Robert, Модератор

Помогите!!!

Сообщение kok2000 » Чт май 15, 2008 12:15 pm

У меня проблемка такого рода!
Пишу прогу точнее уже практически написал но вот наткнулся на такую проблемку! Немогу разобраться с отрецательными числами! программа работает по мультиплексу! Задача программы считаль параметры из агрегара, дать оператору их изменить и записать изменённые параметры обратно в агрегат. Но вот она присчитывании показывает не то число каторое запизанно в агрегате есле оно не положительное! А есле положительное то и записывает и считывает правельно!
kok2000
 
Сообщений: 2
Зарегистрирован: Чт май 15, 2008 12:01 pm
Откуда: Уфа

Сообщение егра » Чт май 15, 2008 2:29 pm

А как неправильно, только знака минус нехватает или совсем другое число выходит?
егра
Специалист LabVIEW
 
Сообщений: 220
Зарегистрирован: Сб сен 01, 2007 10:51 pm
Откуда: Homburg/Germany

Сообщение Vell » Пт май 16, 2008 2:56 am

Привет всем. Помогите чем сможете. Такая задача: необходимо в Labview 6.0 сигнал, подаваемый на плату PCI-6023E разложить в ряд Фурье, постоить спектрамплитуд и спектр фаз, а также определить коэффициент несинусоидальности (ПКЭ).
Vell
 
Сообщений: 2
Зарегистрирован: Вс май 04, 2008 10:08 am

Сообщение kok2000 » Пт май 16, 2008 6:20 am

егра писал(а):А как неправильно, только знака минус нехватает или совсем другое число выходит?

Показывает совсем другое число! Но когда смотриш что она записала в агрегат на другом компе на проге написанной на дельфине он говорит что всё нормально. Тоесть это означает что записывает всё правильно а вот считывает какую-то гадость.
kok2000
 
Сообщений: 2
Зарегистрирован: Чт май 15, 2008 12:01 pm
Откуда: Уфа


Вернуться в LabVIEW

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

cron