Список форумов   Список форумов  

Подключение и управление платой ADLINK PCI-7443

Обсуждение работы в LabVIEW с оборудованием

Модераторы: Техподдержка NI, Robert, Модератор

Подключение и управление платой ADLINK PCI-7443

Сообщение marusenbka » Чт авг 04, 2011 1:37 pm

Уважаемые коллеги!
Помогите пожалуйста разобраться с управлением платой PCI - 7443.
Подскажите, кто писал ПО для ее использования?

Заранее благодарю за помощь!
marusenbka
 
Сообщений: 4
Зарегистрирован: Чт авг 04, 2011 11:55 am
Откуда: Энгельс

Сообщение Knights of the LabView » Пт авг 05, 2011 9:38 am

Добрый день!

К сожалению, мы не занимаемся поддержкой устройств сторонних производителей. Если у вас будут конкретные вопросы именно по программированию в среде Labview, обращайтесь - с радостью вам поможем!

Успехов в освоении!
Knights of the LabView
Специалист LabVIEW
 
Сообщений: 62
Зарегистрирован: Вт май 31, 2011 9:33 am

ADLINK PCI-7443

Сообщение Oleg B. » Сб авг 20, 2011 9:56 am

1. Идете на сайт adlinktech.com
2. Регестрируетесь на сайте (денег не просят)
3. Стягиваете с сайта DAQ-LVIEW-pnp
4. Распакуйте и установите
5. В папке Examples в библиотеке sample.llb найдите файл PCI-7442 Digital I/O.vi
6. Для Вашей карты используйте только DI функцию

Удачи
Oleg B.
Активный пользователь
 
Сообщений: 40
Зарегистрирован: Сб фев 12, 2011 2:30 pm
Откуда: Israel

Сообщение marusenbka » Пн авг 22, 2011 8:56 am

Спасибо конечно, но я так и делала.

Я и демо-видио смотрела. Пыталась сделать как там, но в одном злополучном месте LabView виснет и все!

Кидаю на блок-диаграмму DAQPilotExpress.vi , открывается форма DAQPilotExpress.vi, нажимаю кнопку Create New и все, зависает.

Драйвера качала для Windows 7.
Но мне почему-то кажется, что это из-за семерки.

Запускала PCI-7442 Digital I/O.vi, но ничего у меня не получилось (вылетает ошибка).
Сразу сознаюсь, что практически не имею опыта работы с оборудованием, поэтому буду признательна, если Вы поподробней сможете описать последовательность действий.
marusenbka
 
Сообщений: 4
Зарегистрирован: Чт авг 04, 2011 11:55 am
Откуда: Энгельс

Сообщение marusenbka » Пн авг 22, 2011 9:04 am

Видео
Вложения
_1.rar
Следовала инструкциям по этому видео
(8.36 MiB) Скачиваний: 138
Maria
marusenbka
 
Сообщений: 4
Зарегистрирован: Чт авг 04, 2011 11:55 am
Откуда: Энгельс

ADLINK PCI-7443

Сообщение Oleg B. » Пн авг 22, 2011 10:46 pm

Попробуйте эту функцию
Вложения
1.png
1.png (27.13 KiB) Просмотров: 2545
Oleg B.
Активный пользователь
 
Сообщений: 40
Зарегистрирован: Сб фев 12, 2011 2:30 pm
Откуда: Israel

Сообщение marusenbka » Вт сен 13, 2011 4:02 pm

Спасибо за помощь! :D
Наконец то заработало!
Но заработало только на XP, на 7 все еще не работает.
Maria
marusenbka
 
Сообщений: 4
Зарегистрирован: Чт авг 04, 2011 11:55 am
Откуда: Энгельс

на 7 все еще не работает

Сообщение Oleg B. » Ср сен 14, 2011 12:18 pm

marusenbka писал(а):Спасибо за помощь! :D
Наконец то заработало!
Но заработало только на XP, на 7 все еще не работает.


Проверьте, как указан путь к DLL в вызове фунции.
Укажите абсолютный(полный и правильный) путь.
На рисунке все действия указаны.
Вложения
PCI-LV.png
PCI-LV.png (212.17 KiB) Просмотров: 2430
Oleg B.
Активный пользователь
 
Сообщений: 40
Зарегистрирован: Сб фев 12, 2011 2:30 pm
Откуда: Israel


Вернуться в LabVIEW и оборудование National Instruments

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron