Страница 1 из 1

MAX больше не видит sbRIO 9631

СообщениеДобавлено: Сб апр 06, 2013 7:53 pm
MaPTbIH
Добрый вечер, уважаемая техподдержка,

Пользуемся sbRIO платами уже пару лет. Знаем как пилить под ПЛИС, настраивать IP и прочее.
Но. В Starter Kit 1.0 sbRIO после недавних опытов перестало определяться sbRIO в MAX.
Последовательность действий, которые привели к краху:
1) Неудачная попытка обновить ПО на sbRIO
2) Удачная попытка обновить ПО на sbRIO
3) Изменили Build Specification чтобы запускалась демка автозапуском по инструкции из демки
4) Загрузка автозапуска прошла успешно, но ничего не произошло
5) Загрузка демки Starter Kit Robotics Project 1 и удачный запуск
6) При следующей попытке залить чуть измененный проект (поменяли пару констант в поведении) - Failed to connect
7) В MAX пишет sbRIO находится, но состояние - Safe Mode (Software Error)
8 ) Попытка отформатировать sbRIO, sbRIO перезагружается, MAX виснет.
9) Завершаю процесс MAX, открываю заново, sbRIO не видно в Remote Systems
10) Попытка обнулить IP. Делаем по User Guide к sbRIO. Включаем IP RESET (опускаем 3 рычаг), жмем на кнопку Reset, выключаем IP RESET (поднимаем 3 рычаг). Смотрим в MAX - нет. Ни со IP который был раньше с ним в подсети ни с автоматическим IP компьютера.
11) RIO Device setup показывает вот так как в приложении (1.jpg)
12) Вместо питания аккумулятора подключили блок питания 24V, все те же симптомы
13) Достали другой Starter Kit. Его видит и запускает демку на нем.
Итог:
- У sbRIO режим Unconfigured (Т.к. User LED мигает 1 раз в пару секунд)
- MAX его не видит (Права администратора не могли повлиять, до этого все нормально было, пробовал и запускать насильно с правами администратора - ничего)
- RIO Device Setup видит как 0.0.0.0, но ничего не может сделать
- Моя версия LabVIEW 2011

Что попробовать, чтобы настроить IP sbRIO и продолжить с ним дружить?

Re: MAX больше не видит sbRIO 9631

СообщениеДобавлено: Вт апр 09, 2013 11:20 am
MaPTbIH
Здравствуйте, Кирилл!

Напишите пожалуйста какой Windows у вас установлен, а также версию драйверов NI-RIO. Правильно я понял, что sbRIO теперь вообще никак не отображается в MAX?
Попробуйте сбросить настройки sbRIO нажав на кнопку RESET и подержав ее 5 секунд.

Проблема с подключением с нулевым IP иногда может возникнуть на ОС Windows 7 даже при отключенном firewall (кстати, он у вас отключен?).
Попробуйте произвести те же действия с этим контроллером (форматирование, конфигурирование IP, установка софта) на другом компьютере и желательно с ОС Windows XP.

С уважением, Михаил


Здравствуйте.

Удивительно, но отключение брэндмаура помогло, спасибо вам! sbRIO увиделся в MAX-е.